Failed to notify dependency resolution listener: ContinuousOperation

Some ci machines are running into the following error. This happens on 2.10.

18:20:06.026 [INFO] [] Starting build in new daemon [memory: 5.7 GB]
18:20:06.027 [INFO] [org.gradle.launcher.daemon.server.exec.ForwardClientInput] Closing daemon's stdin at end of input.
18:20:06.027 [INFO] [org.gradle.launcher.daemon.server.exec.ForwardClientInput] The daemon will no longer process any standard input.
18:20:06.029 [DEBUG] [org.gradle.launcher.daemon.server.exec.ExecuteBuild] The daemon has started executing the build.
18:20:06.030 [INFO] [org.gradle.launcher.daemon.server.exec.ExecuteBuild] Executing build with daemon context: DefaultDaemonContext[uid=20529342-08cf-40aa-9fae-dc63a72e8f2f,javaHome=/Library/Java/JavaVirtualMachines/jdk1.8.0_40.jdk/Contents/Home,daemonRegistryDir=/export/home/tester/.gradle/daemon,pid=51824,idleTimeout=10800000,daemonOpts=-Xmx6g,-Dfile.encoding=
18:20:06.383 [DEBUG] [org.gradle.internal.resource.transport.http.JavaSystemPropertiesProxySettings] Found java system property 'http.nonProxyHosts': local|*.local|169.254/16|*.169.254/16. Will ignore proxy settings for these hosts.

FAILURE: Build failed with an exception.

* What went wrong:
Failed to notify dependency resolution listener.
> org/gradle/profile/ContinuousOperation

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 2.479 secs

Hmm… That’s not a very helpful error.

Do you have a custom DependencyResolutionListener that might be failing?

Do you have a full stacktrace?

Nope, no custom DependencyResolutionListener. I don’t have a stack trace. I deleted the gradle instance and had it reinstall and it seems to work. If it does happen again then I’ll try to get a stack trace.