Exception occurred applying plugin request

I’m trying to build this project GitHub - Colby-CPU-Sim/CPUSim using gradle dist but I’m getting this error

Starting a Gradle Daemon (subsequent builds will be faster)

FAILURE: Build failed with an exception.

* Where:
Build file '/home/ms/Documents/coursework/thirdSem/architecture/CPUSim/build.gradle' line: 2

* What went wrong:
An exception occurred applying plugin request [id: 'edu.sc.seis.macAppBundle', version: '2.1.6']
> Failed to apply plugin 'edu.sc.seis.macAppBundle'.
   > Could not get unknown property 'runtime' for configuration container of type org.gradle.api.internal.artifacts.configurations.DefaultConfigurationContainer.

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
> Get more help at https://help.gradle.org.

Deprecated Gradle features were used in this build, making it incompatible with Gradle 9.0.

You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.

For more on this, please refer to https://docs.gradle.org/8.4/userguide/command_line_interface.html#sec:command_line_warnings in the Gradle documentation.


I’m new to java, I can’t figure out how to build and install the project. I’ve tried installing the latest jdk and gradle versions because ubuntu repos contain really old packages. I’ve also tried to set the JAVA_HOME variable correctly but nothing seems to be working out :frowning:

Installing the latest JDK is most probably a bad idea, as latest would mean 21 and there is no Gradle version compatible with running on 21 officially: Compatibility Matrix

Which Gradle version you install - or whether you install any Gradle version at all - usually is pointless, as each and every Gradle project imho should contain the 4 Gradle wrapper files and you should always use the wrapper to run a Gradle build, as these files define exactly with which version of Gradle a build should run with as it is designed for that and known working as expected with it.

The error you get is, because the plugin you try to apply is not compatible with the Gradle version you use. It tries to access something that was deprecated already many many maaany years and finally was removed in Gradle 7.0, so this plugin cannot be used with anything Gradle 7 or newer.