Error: Unable to start the daemon process

I was trying to make Minecraft mods so I followed a tutorial. I typed in “gradlew genEclipseRuns” and I got an error. I put the entire error in this Pastebin: Gradle Error. Here’s the link to the tutorial if that helps also: Tutorial
Windows 10|JDK-16|Gradle 4.9|Eclipse 2021-03

Gradle 4.9 is ancient and not compatible with running on Java 16.
Gradle 7.0 officially added Java 16 support.

What versions of java are compatible with Gradle 4.9?

Maximum Java 9, but I’d instead not use an ancient Gradle version.

I updated to Gradle 7.0 and I’m getting the same error message.

Can you provide an MCVE?

Question… what exactly is an MCVE?

The best I can minimize it down to is this: build.gradle.

This for me fails with

Failed to apply plugin 'net.minecraftforge.gradle'.
Found Gradle version Gradle 7.0. Versions Gradle 6.0.0 and newer are not supported in FG3, FG4 however supports Versions 6.8.1 and newer. Consider upgrading.

Last question, how do I update FG3 to FG4?

I believe the error message is from the ForgeGradle plugin. Update the version of the net.minecraftforge.gradle:ForgeGradle plugin declared in the buildscript classpath dependencies from 3.+ to 4.+.

1 Like

Sorry I haven’t responded in a while. I changed the 3.+ into 4.+ and the problem is still occurring. I made sure to save it when I changed it. I get the exact same error as before.

I’d guess you are still not using Gradle 7 in your build.
If I change in your given build script 3.+ to 4.+, I still get the complaint that ForgeGradle is not compatible with that Gradle version, but that ForgeGradle 5 will add support for it.