Eclipse error: Could not find matching constructor for org.gradle.api.GradleScriptException(java.lang.String)


(Joe Belisle) #1

When I import a gradle project into Eclipse, any gradle-based action results in the error, “Could not find matching constructor for: org.gradle.api.GradleScriptException(java.lang.String)”

I get this error even when I simply am trying to do a Gradle > Refresh Dependencies.

Sometimes this error is also accompanied by the error, “Could not fetch model of type ‘EclipseProject’ using Gradle installation ‘C:\gradle-1.7’.” I have tried this with multiple versions of gradle and get the same behavior with each.

Others are able to bring the project up without any issues, so it doesn’t seem to be an issue of project configuration, but I can’t figure out what is going wrong with my setup.

I am running Eclipse Kelper with the “Gradle IDE Pack 5.6.x, 0.15.1” and “Gradle Integration for Eclipse 3.5.1.RELEASE” plugins installed.

Any ideas?


(Radim Kubacki) #2

No idea. I haven’t tried Gradle IDE Pack (BTW: is the version number really 5.6.x?) and think that “Gradle Integration for Eclipse 3.5.1.RELEASE” plugin should be enough. If you have a chance to compare it with a working setup I’d try to make sure that Eclipse, installed plugin and Gradle are the same.