Eclipse 4.12 with Buildship 3.0 does not read project dir gradle.properties file

Hi there, I run into a problem that I need help with. I use the latest Eclipse 4.12 and installed the latest Buildship Gradle Integration 3.0 as of last week. I am able to see the Gradle tasks in the Gradle Tasks view.

When I run a task from the Gradle Tasks view it fails with an exception message

Path[src] does not exist

src is a directory defined as GEN_ROOT_PATH=src in the project directory gradle.properties file. The path exists. When I run the task from the command line it runs successfully.

The thought that I had was that the project dir in command line is known correctly but when run from Eclipse maybe it somehow finds itself somewhere else and of course cannot find src. I don’t know how to test or approach that issue. I would appreciate some help with this topic.

I tried to ask on StackOverflow but could not find much help unfortunately. (For those who use SO https://stackoverflow.com/q/57612262/1566187)

Without seeing the sources I can only guess, but I have an idea. Can you please try the following: in the Tasks view open the menu (upper right corner) and make sure that both Project tasks and Task selector are enabled. Then, you’ll see the tasks duplicated in the view. Try executing both. If I’m lucky, one should succeed :slight_smile:

If not, please extract a minimal example from your project that exhibits the problem, upload it here, and I’ll investigate further.

Thank you Donát for the reply. I tried as described. Unfortunately I get the same error message in both attempts.

I will try to extract a minimal example these days and come back to this thread.