Dynamic version ranges broken (or at least, different) in Gradle 1.9


(William Lichtenberger) #1

Using version notation below works with gradle 1.7 and 1.8, but is broken in 1.9.

repositories {
  mavenCentral()
 }
 configurations {
  config
 }
 dependencies {
  config 'junit:junit:[4.10,4.+]'
 }

I looked at the release notes and did not find any reason for this to have broken. Is there a better way to approach this functionality?


(William Lichtenberger) #2

Also, I guess I never specified. When running ‘gradle dependencies’ with 1.9 the output is

:dependencies


Root project


config

— junit:junit:[4.10,4.+] FAILED


(Peter Niederwieser) #3

Actually it doesn’t work in 1.8 either (only 1.7). This is likely related to some major internal refactorings we did in the dependency management code. Raised GRADLE-2961. Thanks for reporting.