Discrepancy between gradle and gradlew


(Jesper Thuun-Petersen) #1

I’m developing our new gradle based build system. I have no problems running this command:

gradle -Dtest.single=InboundMessageHandlerServiceTest :import:importservices:test

Our developers don’t install gradle, but use the gradlewrapper instead. They (and I) can’t run the command above with gradlew, as they get this error:

...
...
:buildSrc:remoteservice:compileJava UP-TO-DATE
:buildSrc:remoteservice:compileGroovy
:buildSrc:remoteservice:processResources
:buildSrc:remoteservice:classes
:buildSrc:remoteservice:jar
:buildSrc:stiboosgi:compileJava UP-TO-DATE
:buildSrc:stiboosgi:compileGroovy
:buildSrc:stiboosgi:miniBndJar
:buildSrc:stiboosgi:processResources
:buildSrc:stiboosgi:classes
:buildSrc:stiboosgi:jar
:buildSrc:test FAILED
  FAILURE: Build failed with an exception.
  * What went wrong:
Execution failed for task ':test'.
> Failed to notify test listener.
   > Could not find matching test for pattern: InboundMessageHandlerServiceTest

The detailed logs for both runs are here: https://gist.github.com/anonymous/5459326

If I run the ‘proper’ gradle first, the gradle wrapper will happily build and run the tests.


(René Groeschke) #2

does gradle and gradlew to different gradle versions? does this error go away when running a ‘clean’ build? cheers, René


(Jesper Thuun-Petersen) #3

No, they’re the exact same version.

I just tried a gradle clean and then the gradlew command - it actually went past the buildsrc problem and started building my project! Unfortunately, when I executed the gradlew command immediately afterwards, the error mentioned above showed up again?!!


(René Groeschke) #4

weired. do you use the gradle daemon?


(Jesper Thuun-Petersen) #5

I have upgraded to 1.6 and tried running with --no-daemon.

It works perfectly with ‘gradle’ and fails miserably with ‘gradlew’. Everything else seems to be working ok with the wrapper, though!

Regards /Jesper