Declared dependency is unexpectedly resolved to `project(":")`

Hi! I have a library which depends on its previous (published) version transitively.
Project (dataframe) → symbol-processor:0.8.0-dev-939dataframe:0.8.0-dev-939
Dependency is declared like this:
Project compiles if project version is 0.8.0
If I change the project version to 0.9.0, it fails with cyclic dependency between tasks.
So i run the following command to check how this dependency is resolved:
./gradlew -q dependencyInsight --dependency dataframe --configuration kspKotlinProcessorClasspath
With project version 0.8.0 i get

But with project version 0.9.0 i get (note → project after module):

I checked the pom file and there dependency is exactly on dataframe:0.8.0-dev-939 module, so i don’t understand why project shows up.

I tried to debug componentSelection, but with later version org.jetbrains.kotlinx:dataframe module is not in the list of components if i try to build the project with this code:

configurations {
    all {
        resolutionStrategy {
            componentSelection {
                all {

Is there some solution to resolve published artifact and not the project, as it happens with project version 0.8.0?