Could not create JNA native library


(Steven Ford) #1

I am getting an exception when I run Gradle: org.gradle.internal.nativeplatform.NativeIntegrationException: Could not create JNA native library. The weird thing is that it can’t find a file /home/carlos/.gradle/jna/libjnidispatch.jnilib’. I have no idea who carlos is, why would it be looking in /home/carlos?


(Peter Niederwieser) #2

Either ‘/home/carlos’ is your user home directory, or you have configured the Gradle user home directory to be ‘/home/carlos/.gradle’.


(detelinyordanov) #3

How are you running Gradle? Are you using ‘sudo’?


(Tim Bassett) #4

this might be a permission problem to where you have specified the gradle_home to be. we had a custom one and I 777’d it and the problem went away


(Dan Hunt) #5

on windows create a system environment variable called GRADLE_USER_HOME to somewhere you can write to. A similar problem happens for Grails which can be solved by using grails -duser.home=c:/users/myuser or setting the system property in eclipse under window->preferences->Groovy->Grails Launch -> variable user.home value c:/users/xxx/mypaththaticanwrite to