I switch to gralde 8.5 with java 21 and I also upgraded the plugin

plugins {
    id "com.devsoap.plugin.vaadin" version "2.0.0.beta2"

But on gradle build getting below error:

An exception occurred applying plugin request [id: 'com.devsoap.plugin.vaadin', version: '2.0.0.beta2']
> Failed to apply plugin 'com.devsoap.plugin.vaadin'.
   > No signature of method: org.gradle.api.internal.artifacts.ivyservice.dependencysubstitution.DefaultDependencySubstitutions$1.with() is applicable for argument types: (org.gradle.internal.component.external.model.DefaultModuleComponentSelector) values: [javax.validation:validation-api:1.0.0.GA]
     Possible solutions: with(groovy.lang.Closure), with(boolean, groovy.lang.Closure), wait(), wait(long), find(), wait(long, int)

Any help would be appreciated.

That plugin is not compatible with Gradle 8+.
It uses API that was removed in 8.0.

Thanks to inform me but is there any replacement of this plugin with Gradle 8+. I want to use the vaadinCompile task of it.

I have not the faintest idea.
You probably should ask the maintainers for that plugin, or search on or Google.

Thanks for your reply

Getting below error with gradle 8.5 and java version 21.

[error] target level should be in ‘1.1’…‘1.8’,‘9’…‘16’ (or ‘5.0’…‘16.0’) or cldc1.1: 21

Do you know what it could be ?

Please do not hijack threads, not even your own ones. :slight_smile:
New unrelated question should better be a new thread, as this is a forum, not a chat. :slight_smile:
For more chat-like experience, you could join the Gradle Community Slack.

But regarding the question, whereever that error comes from does only support “target level” up to Java 16, but you told it to use.

A quick Google search turns up compilation - After updating to java 17 started to receive [error] target level should be in '1.1'...'1.8','9'...'14': 17 - Stack Overflow which which suggests you are using AspectJ 1.9.7 which only supports up to Java 16 and according to there is not yet a version supporting Java 21.