Best Recommendation for Gradle/Groovy plugins for Eclipse IDE

Hello Community

According with your valuable experience, could you suggest me your best recommendation about a plugin for Gradle and Groovy for Eclipse IDE?

I work with STS based on Eclipse.

Thank you

I also use STS and have tried both Buildship and Pivotal’s Gradle plugins. Buildship is one to watch, but I find I can get more gradle work done more effectivley within Eclipse using Pivotal’s plugin:

Hoobajoob, could you explain in more detail what makes you favor STS over Buildship?

Manuel, I suggest to give Buildship a spin, the official Gradle Plugin for Eclipse, implemented by the Gradle Core team. Buildship is also shipped with several Eclipse Mars distributions out of the box.

At the time that I tried Buildship, which was probably the 1.0 release (I haven’t tried more recent releases), I wasn’t able to get the plugin to display tasks for the project, there was no quick mechanism (that I could find) to launch a build from a context menu or keystroke, there wasn’t a way (or I couldn’t find the way) to refresh build dependencies, and I also don’t seem to remember being able to get it to use the wrapper instead of the installed version. I recall documentation also being hard to find or sparse, so I just decided to stick with STS at the time.

I’ll give the current release another run - the feature summary looks more promising than what I remember about my first experience.


Thanks to both by your replies.

I already use (It from STS Dashboard - IDE Extensions):

  • Gradle Support
  • Groovy 2.4 Compiler for Groovy-Eclipse
  • Groovy-Eclipse (it is key for me, thanks to this the STS recognize the groovy syntax for either .gradle and .groovy file)

Until here I have no problem. But since Pivotal does not support Groovy anymore I must think in the future. That’s why I have created this post.

Now this latest weekend I have tried the Buildship Gradle Integration, therefore the latest available. I did that through a clean installation of STS 3.7.2.RELEASE Based on Eclipse 4.5.1.

It works. But how I have shared in other post:


I just installed this plugin and I did realize the same situation about I can't see the "build" directory through the Explorer View with the libs (for a .war) and reports (gradle testing) even spock-reports directory

Some way to fix permanently this situation?


Furthermore since I have installed Buildship Gradle Integration I have the following

Even when I have removed Buildship Gradle Integration

Why I have removed Buildship Gradle Integration?

  • It does not show the build directory (I can’t see reports, spock-reports and libs directories through the Explorer view anymore)
  • It does not apply the “expected” recognition of Groovy syntax. Even if I open the build.gradle file it opens how a simple file text.
  • I have that icons in red shown above. (Even when I have removed the plugin)

Perhaps I must expect a next release where that issues has been fixed.

BTW: I have read this valuable tutorial:
Using the Gradle build system in the Eclipse IDE - Tutorial

Kind Regards.

I just gave the latest Buildship a spin, and haven’t encountered any problems finding and running available tasks, and I like the Task View output showing the step sequencing of each gradle execution. So far, it looks good.

I’m not seeing any syntax recognition of build.gradle though, either. I assume I was getting that from Pivotal’s plugin before.


and I like the Task View output showing the step sequencing of each gradle execution

I like that too.

BTW I can use both views Gradle Executions and Gradle Tasks, of course is mandatory re-import the Gradle project to be managed by Buildship, just curious why appears in red these two items in my STS

But I am going to wait a new release to see if some issues are fixes or not.

@dr_pompeii Which version of Buildship/Eclipse that bundles Buildship have you been using that renders the icons in red?

@dr_pompeii: I’m finding that the default build script editor that comes with Buildship does not support syntax highlighting. I’m not exactly sure what it does support other than the ability to view the file.

I have been able to get syntax highlighting (at least) using the Minimalist Gradle Editor in the Eclipse Marketplace:

…I imagine the full Eclipse-Groovy plugin is meeting all the language-specific needs you have.

I recently checked the latest version of the Pivotal plugin and doesn’t seem to support DSL auto-completion anymore. You’d probably just have to open the build.gradle file as Groovy file to get Groovy syntax highlighting.

You are seeing the red squares instead of icons because you probably deinstalled on the Gradle plugins. If one plugin gets uninstalled sometimes the corresponding metadata is not cleaned up which results in non-exising menu items. This is a known issue in Eclipse. You can run ./eclipse -clean to fix it.

Yes they removed the DSL support together with their removal of Groovy-Eclipse plugin support.

For me, a showstopper is the lack of support of WTP by Buildship.
For other noteworthy limitations of Buildship compared to the Pivotal Plugin see here:
see the section “Known limitations of BuildShip Gradle integration”.

Anyway, is nobody really worried about the future of Groovy on the Eclipse IDE, since the current state of the Groovy-Eclipse plugin?
It has always been barely usable (crowded with serious bugs and limitations) and now it’s also unmaintained and without future… I even wonder if it will work on the next Eclipse release (on Mars I have to restart the IDE on every other launch to make things somewhat working…).

Even if Gradle support has a shining future in Eclipse thanks to Buildship, I’m seriously considering to convert all my Groovy codebase to something else (probably Java…) because of this uncertainty. The Groovy team clearly stated that they have no time to spend on Eclipse support and even if I periodically search the Internet for this subject I really find nobody which cares about this :frowning:

Hello community

Thanks by your thoughts.

@bmuschko I am using

I have created a new STS/Workspace installation and all works fine. No Red items.

You can run ./eclipse -clean to fix it.

I have tried twice ./ -clean and nothing, remains the red squares.

It of course for my other old STS/Workspace installation.

The important is, in the other installation directory there is no errors.

@chefhoobajoob thanks by the Minimalist Gradle Editor in the Eclipse Marketplace recommendation. Just wondered why does not exists yet a Groovy plugin.

@mauromol I need Groovy support since I work with Spock Framework. That is very useful for Testing. The source code is based totally on Groovy.

Kind Regards!