Android Studio gradle issue


(Mahmoud Ahmed) #1

I have Android Studio (I/O Preview) 0.3.1 on Windows 7 and JDK 1.7 I am getting the following error when I tried to create new project.

I googled and found a lot of different responses from Stack Overflow and Google groups, but none helped.


Unable to start the daemon process. This problem might be caused by incorrect configuration of the daemon. For example, an unrecognized jvm option is used. Please refer to the user guide chapter on the daemon at http://gradle.org/docs/1.8/userguide/gradle_daemon.html Please read below process output to find out more: ----------------------- java.lang.IllegalArgumentException: URI has an authority component

at java.io.File.(File.java:397)

at org.gradle.api.internal.classpath.EffectiveClassPath.findAvailableClasspathFiles(EffectiveClassPath.java:41)

at org.gradle.api.internal.classpath.EffectiveClassPath.(EffectiveClassPath.java:32)

at org.gradle.api.internal.classpath.DefaultModuleRegistry.(DefaultModuleRegistry.java:61)

at org.gradle.api.internal.classpath.DefaultModuleRegistry.(DefaultModuleRegistry.java:55)

at org.gradle.launcher.bootstrap.ProcessBootstrap.runNoExit(ProcessBootstrap.java:41)

at org.gradle.launcher.bootstrap.ProcessBootstrap.run(ProcessBootstrap.java:32)

at org.gradle.launcher.daemon.bootstrap.GradleDaemon.main(GradleDaemon.java:22)

Consult IDE log for more details (Help | Show Log)


(Luke Daley) #2

Is your project being opened over a UNC path?

Is your GRADLE_USER_HOME env var set to be a UNC path?


(Luke Daley) #3

This has also been reported here: https://code.google.com/p/android/issues/detail?id=56444


(Luke Daley) #4

This is related to GRADLE-2941.


(Mahmoud Ahmed) #5

No I have not set any env. What is UNC path? The gradle that I am using comes with the Android Studio.

Thanks,


(Luke Daley) #6

What is UNC path?

A Windows network share. For some reason, Gradle is being run off a network share and this is not supported on Windows.


(Mahmoud Ahmed) #7

In the Usage and troubleshooting it said

“If you have a problem with your build, try temporarily disabling the daemon (you can pass the command line switch --no-daemon)” How do you disable the deamon? Where do you put the swith --no-deamon?

Thanks,


(Peter Niederwieser) #8

Android Studio can’t be run without the Gradle daemon (only plain Gradle can).


(Mahan Rad) #9

Whats the solution to it?