Update to Gradle issue 2912 (loader constraint violation: loader (instance of org/gradle/util/MutableURLClassLoader) previously initiated loading for a different type with name "org/apache/http/HttpHost")

This is in the old issues area, so I’m not sure if I should update it there (which I did), or open something new here.

In any case, I’ve updated the old issue:
https://issues.gradle.org/browse/GRADLE-2912

This has to do with upgrading version of Gradle experiencing loader constraint errors relating to HttpHost/HttpCore.

Let me know if I need to refile a bug here.

Hi Doug.

I’ve linked this to the JIRA issue.

Off the top of my head I’ve got no idea what’s going on. I’ll take a look.