Unable to resolve com.google.android.exoplayer2 after Gradle update to v 5.4

android
(Josef Vančura) #1

My project is using com.google.android.exoplayer2. Until today I was at gradle 4.10.1 (android gradle plugin 3.3.1) - all fine. Once i updated to Gradle 5.4.1 exoplayer can not be resolved. Android Studio 3.4.
I used update guide form Gradle 4 to 5 ( https://doc s.gradle.org/current/userguide/upgrading_version_4.html#upgrading_version_4) and also troubleshooting guide without any progress.

Module gradle (no change)

implementation 'com.google.android.exoplayer:exoplayer:r2.5.2'

Project gradle (was 3.3.1)

  dependencies {
    classpath 'com.android.tools.build:gradle:3.4.0'

Gradle wrapper properties (was 4.10.1)

distributionUrl=https\://services.gradle.org/distributions/gradle-5.4.1-all.zip