Unable to link dependency sources

Hi, sources linking doesn’t work only for this dependecy
“com.destroystokyo.paper:paper:1.13.2-R0.1-SNAPSHOT” taken from the repo “Repository - Nexus Repository Manager”, anyone happen to knows why?

P.S. Linking works for other dependencies and the source jar is being downloaded (I’ve looked inside the gradle cache folder)

I’ve already tried to remove the downloaded source jar from the cache but that doesn’t change anything.

When you say you “removed the downloaded source jar”, what did you remove?
You said the download did not work, so what was there to delete?
Also, Gradle does not automatically download any sources.
It is for example the IntelliJ IDEA sync execution that downloads and links those source jars.
So maybe try to refresh your Gradle project in your IDE so that the sources get downloaded.

Sorry chose the wrong word, it’s not that it isn’t downloading. It’s not linking the downloaded source.
Btw I thought that it was buildship that had the job to link downloaded sources.

Ah right, didn’t look at the “Buildship” category.
So yes, Buildship is the IDE integration for Eclipse that should trigger the download through Gradle and then link the sources.
If that does not work, I cannot help though, I’m not using Eclipse.

Same problem happens on IntelliJ IDEA…

Works fine here with IJ:

Uhm, I tried it a bit of time ago so I wasn’t sure. Ty for your time.

I asked on the GH discussion of the java language server extension for vs code given that is the thing that implements buildship.