Unable to find .jar

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine the dependencies of task ':randompackage-spigot:shadowJar'.
> Could not resolve all files for configuration ':randompackage-spigot:runtimeClasspath'.
   > Could not find askyblock.jar (com.wasteofplastic:askyblock:3.0.9.4).
     Searched in the following locations:
         http://ci.ender.zone/plugin/repository/everything/com/wasteofplastic/askyblock/3.0.9.4/askyblock-3.0.9.4.jar

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3s

How can i make a work around or what can i do about this…?
and what about the other errors??

You configured a repository for dependency lookup where said dependency is not present. According to GitHub - tastybento/askyblock: A skyblock plug for Minecraft Bukkit. *No longer in development* See:</titl the repo you should use is https://repo.codemc.org/repository/maven-public, but actually it also says ASkyBlock is no longer maintained and you should use BSkyBlock instead.

Hello, thanks for your response but, im no where experienced at all in any of this, my apologies. but i don’t have the knowledge to change this.

Do you have any idea to change the jar ? or whatever i have to do?

If it isn’t this where to change it in… then i wouldn’t know at all.

apply plugin: 'idea'
apply plugin: 'maven'
apply plugin: 'java-library'

repositories {
    mavenLocal()
    maven {
        url = 'https://hub.spigotmc.org/nexus/content/repositories/snapshots'
    }

    maven { url "http://repo.extendedclip.com/content/repositories/placeholderapi" } // PlaceholderAPI
    maven { url "http://dl.bintray.com/tastybento/maven-repo" } // ASkyblock
    maven { url "http://nexus.hc.to/content/repositories/pub_releases" } // Vault
    maven { url "https://jitpack.io" } // SuperiorSkyblock API
    maven { url "http://ci.ender.zone/plugin/repository/everything/" } // FactionsUUID
    //maven { url "http://repo.mvdw-software.be/content/groups/public/" } // MVdWPlaceholderAPI
    /*maven {
        name = "WorldEdit and WorldGuard"
        url = "https://maven.enginehub.org/repo/"
    }*/

    /*
        EpicSkyblock -> https://www.spigotmc.org/resources/62480/ | https://github.com/PeachesMLG/EpicSkyblock

        SilkSpawners -> https://dev.bukkit.org/projects/silkspawners | https://github.com/timbru31/SilkSpawners
        EpicSpawners -> https://songoda.com/marketplace/product/13 | https://gitlab.com/Songoda/epicspawners

        McMMO Classic -> https://www.spigotmc.org/resources/2445/ | https://github.com/mcMMO-Dev/mcMMO-Classic
        McMMO Overhaul -> https://www.spigotmc.org/resources/64348/ | https://github.com/mcMMO-Dev/mcMMO
     */
}

dependencies {
    // You need to add the Spigot jars yourself, otherwise you need to use BuildTools and import them
    compileOnly 'org.spigotmc:spigot:1.14.4-R0.1-SNAPSHOT'
    //compileOnly 'org.bukkit:craftbukkit:1.13.2-R0.1-SNAPSHOT'
    //
    implementation 'me.clip:placeholderapi:2.10.3'
    implementation 'net.milkbowl.vault:VaultAPI:1.7'
    implementation 'com.wasteofplastic:askyblock:3.0.9.4'
    implementation 'com.github.OmerBenGera:SuperiorSkyblockAPI:b7'
    implementation 'com.massivecraft:Factions:1.6.9.5-U0.5.3'
    //implementation 'be.maximvdw:MVdWPlaceholderAPI:3.0.0'
    //implementation 'com.sk89q.worldguard:worldedit-bukkit:7.0.1'
    //implementation 'com.sk89q.worldguard:worldguard-bukkit:7.0.1-SNAPSHOT'

    //implementation 'com.gmail.nossr50:mcMMO:LATEST'
}

configurations {
    compile.exclude group: 'com.typesafe'
    compile.exclude group: 'org.apache'
    compile.exclude group: 'org.kitteh'
    compile.exclude group: 'org.spongepowered'
    compile.exclude group: 'commons-codec'

    compile.exclude group: 'com.darkblade12'
    compile.exclude group: 'org.hamcrest'
    compile.exclude group: 'me.lucko'
    compile.exclude group: 'mkremins'

    compile.exclude group: 'com.google.guava'
    compile.exclude group: 'com.google.code.gson'
    compile.exclude group: 'com.googlecode.json-simple'

    compile.exclude group: 'org.yaml'

    compile.exclude group: 'junit'
    compile.exclude group: 'commons-lang'
}

jar {
    baseName = pluginId
}

shadowJar {
}

build.dependsOn(shadowJar)

I believe i fixed the jar issue but now a new one popped up

> Task :randompackage-spigot:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':randompackage-spigot:compileJava'.
> Could not resolve all files for configuration ':randompackage-spigot:compileClasspath'.
   > Could not find spigot.jar (org.spigotmc:spigot:1.14.4-R0.1-SNAPSHOT).
     Searched in the following locations:
         http://ci.ender.zone/plugin/repository/everything/org/spigotmc/spigot/1.14.4-R0.1-SNAPSHOT/spigot-1.14.4-R0.1-SNAPSHOT.jar

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 5s
5 actionable tasks: 1 executed, 4 up-to-date

C:\Users\theda\Desktop\RandomPackages\randompackage-multi-master\randompackage-multi-master>

It’s the same problem. You declare a dependency, but not the correct repository where it can be found.

Thanks again, any idea where i can find those repositories?
like what do i search for?

Usually the best source is the homepage / documentation of the library in question.