Trying to use libGDX to create a project in Eclipse

I dont understand why im getting this error.

  • What went wrong:
    Task ‘eclipse’ not found in root project ‘Eclipse’.

Take it easy on me I’m a total noob when it comes to Eclipse, libGDX, Gradle. and Java.

Hi @SirFency ,

The question is very vague. This sounds like the “eclipse” plugin is not applied. I.e. you build script is missing:

apply plugin: "eclipse"

But you should also not need this necessarily as you can import Gradle projects in Eclipse without it. If you get this error for a project generated by LibGDX tooling, you can probably get better help in the LibGDX forum.

Otherwise, please post a bit more context. Like: What are you trying to do when you get the error? Where are you getting the error (Eclipse, command line, etc)? How does your build.gradle look like?

I appreciate the reply. So I was trying to build a project using libGDX that I was going to open in eclipse. The build fails every time. I tried to set up the advanced settings to include eclypse. I tried building the project in different directories. I included the bare minimum check boxes I thought I would need in order to practice with.

My main goal is to build games that work on Android (eventually a full blow RPG). I have no idea what I’m doing. I spent a couple months learning Java only to find out that I may need to know how to program Kotlin to get my apps into the Android platform.

Anyhow, Its frustrating to say the least when I cant even get past the build stage in libGDX. The only reason I asked here is because it told me to get help here in the console after it failed.

I’m currently trying to figure out what I actually need to know in order to reach my main goal of building games for, and putting games on, the Android Operating System.

Thank again for your time.