Trying to get 3.3 working android studio and other bugs


(David K) #1

Error:Could not find com.android.tools.build:gradle:3.3.0.
Searched in the following locations:
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.pom
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.jar
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.pom
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.jar
Required by:
:AndroidLoginAndRegistration:unspecifiedError:Could not find com.android.tools.build:gradle:3.3.0.
Searched in the following locations:
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.pom
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.jar
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.pom
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.0/gradle-3.3.0.jar
Required by:
:AndroidLoginAndRegistration:unspecified

I used sdk to install gradle and I run into this error … heres my build.gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
repositories {
jcenter()
}
dependencies {
classpath ‘com.android.tools.build:gradle:3.3.0’
}
}

allprojects {
repositories {
mavenCentral()
}
}

If I try using an older version, I get this error…

Error:java.lang.NullPointerException (no error message)

classpath ‘com.android.tools.build:gradle:2.2.3’

Here is the stacktrace
https://hastebin.com/eroyumibut.sql

Please help me with one or the other.

If i try 2.14.1 i get this error

Error:Could not find com.android.tools.build:gradle:2.14.1.
Searched in the following locations:
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.pom
file:/Applications/Android Studio.app/Contents/gradle/m2repository/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.jar
https://jcenter.bintray.com/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.pom
https://jcenter.bintray.com/com/android/tools/build/gradle/2.14.1/gradle-2.14.1.jar
Required by:
:AndroidLoginAndRegistration:unspecified

HELP!!


(Samsuddin Midday) #2

Try This -
Go To File> Project Structure > Project > And change the gradle version to the one you were using before.
Change build.gradle(Project : app_name) > classpath ‘com.android.tools.build:gradle:3.3.0’ to the one you used in gradle version settings.
Let me Know if it worked.
Take Care.


(Shankar Uthirapathy) #3

Hi,

Recently I have updated Android Studio to 2.3 and it asked to have Gradle 3.3, even I apply the above changes, I am getting similar error.

I tried to download and unpack Gradle 3.3 and gave that in ENV var also, but no luck.

Error:Could not find com.android.tools.build:gradle:3.3.
Searched in the following locations:
file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/3.3/gradle-3.3.pom
file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/3.3/gradle-3.3.jar
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3/gradle-3.3.pom
https://jcenter.bintray.com/com/android/tools/build/gradle/3.3/gradle-3.3.jar
Required by:
project :


(Samsuddin Midday) #4

Dont use 3.3 yet, instead use gradle 2.3 in your Settings(Project Structure > Project).
And also in your build.gradle as I’ve explained in my previous reply. Try it and tell me if it worked…


(Khalid) #5

@Sam-Midday I have the same error with 3.3 and i use 2.3 i got this error:

Error:Cause: https://downloads.gradle.org/distributions/gradle-2.3.0-all.zip

Thank you


(Shankar Uthirapathy) #6

Thanks after trying many things it worked out. The issue was Android Studio 2,3 and it’s default gradle version is 3.3.

I accidentally updated SDK build tools to latest one 25.0 .0, after Android Studio popped up message to update and Gradle plugin version to 2.3.0 for which required gradle version is 3.3+.

I did the below changes to fix the issue:

  1. Installed older SDK build tools 19.1.0 to use previous Gradle versions
  2. File> Project Structure > Project > And change the gradle version to 2.3.0
  3. Changed build.gradle(Project: app_name) > classpath ‘com.android.tools.build:gradle:3.3.0’ to ‘com.android.tools.build:gradle:2.1.2’

(NahimRGz) #7

Thank you very much, i had this problem a lot of time