The software in your host aborts an established connection when building a project

Gradle always prompts me when I’m building a project, “The software in your host has aborted an established connection.”

Here’s the diagram.

image-20201012215941312|690x271, 100%

Of course I already know what caused it.Because I turned on my computer’s network hotspot.Here’s the diagram.

image-20201012220405099|396x381, 75%

Once I turned off my computer’s network hotspot, Gradle was able to compile the project properly. Or you can use Gradle to compile the project first and then turn on the network hotspot, which seems to allow the network hotspot to be on other ports. Nevertheless, I was wondering if there is any other solution to this problem. Because sometimes it’s a bit inconvenient to turn off the network hotspot. This is the first problem.

Here is the second question.

As shown in the diagram, the diagrams are all in Chinese prompt. So, I was going to use the English environment for the screenshot. But when I changed the language of my computer, I tried to compile the project using Gradle again.

image-20201012221555210|578x500, 75%

Then, Gradle’s compilation seems to go into a dead loop. The memory is also getting bigger.

image-20201012231805538|564x500, 75%