The import org.gradle.api.Action cannot be resolved


(Aydin) #1

I am using Eclipse Neon. I downloaded the latest 4.1 version today. I also have a bunch of other imports not working, see below.

import org.gradle.api.Action;
import org.gradle.internal.UncheckedException;
import org.gradle.internal.io.ClassLoaderObjectInputStream;
import org.gradle.internal.serialize.Decoder;
import org.gradle.internal.serialize.InputStreamBackedDecoder;
import org.gradle.internal.logging.LoggingManagerInternal;
import org.gradle.internal.logging.services.LoggingServiceRegistry;
import org.gradle.internal.remote.MessagingClient;
import org.gradle.internal.remote.ObjectConnection;
import org.gradle.internal.remote.services.MessagingServices;
import org.gradle.internal.remote.internal.inet.MultiChoiceAddress;
import org.gradle.internal.remote.internal.inet.MultiChoiceAddressSerializer;

I have the GRADLE_HOME as C:\gradle-4.1
I have C:\gradle-4.1\bin;C:\gradle-4.1\lib;C:\gradle-4.1\plugins; added to the PATH variable

What can possibly cause that?


(BrainStone) #2

Have you added the gradle jar as a dependency in the project?