Supplied javaHome is not a valid folder


(Mark E. Scott, Jr.) #1

One of my coworkers updated their version of the JDK, and has been having nothing but issues.

At this point, he gets “Launching Gradle tasks failed due to an unexpected error”
"Supplied javaHome is not a valid folder. You supplied: "

We think we’ve changed the right locations. Where else can we look? It works from the command line using gradlew build, etc.


(Lalit Sharma) #2

Under folder “.settings” I had to correct the default value for connection.java.home in org.eclipse.buildship.core.prefs.

To see “.settings” folder use Eclipse Navigator view.


(Stefan Oehme) #3

Please use your gradle.properties for specifying the Java home. The support for overwriting it in Eclipse like this will be removed in Buildship 2.0.


(Mark E. Scott, Jr.) #4

In the end, the workaround we used was to re-import the Gradle projects. We didn’t try setting it in gradle.properties. Will try that the next time.