[SOLVED]Missing dependencies - gradle wrong group📦version


(gls) #1

edit :
I tried a test project with mavenCentral() and not our artifactory.

dependencies {
compile ‘org.apache.poi:poi:3.15-beta2’
}

I still get “poi-3.15-beta2:15-beta2” in the dependencies list. Is there something wrong with the package ? I get that with all the versions I can find on maven repository.

edit 2 : it seems that the problem comes from intellij. If I open a project that works and change the version then refresh dependencies, the same thing happens with any dependency.

**edit 3 : sorry for the multiple edits, I found what the problem was. In IntelliJ : **
File -> Settings -> Build, Execution, Deployment -> Gradle
There is a checkbox “Offline work” at the bottom and it was checked. I don’t know why because I never checked it.


Good morning,

my company is using its own repository using artifactory (I suppose it is linked to the maven central repository).

I am trying to import the package “poi” from “org.apache.poi” but it doesn’t work. Here is the result compared to something that works (in that example, pdfbox).

build.gradle:
dependencies {
compile group: ‘org.apache.poi’, name: ‘poi’, version: '3.14’
compile group: ‘org.apache.pdfbox’, name: ‘pdfbox’, version: ‘1.8.2’
}

dependencies list in IntelliJ :

poi-3.14:14 (I should have org.apache.poi:poi:3.14, right?)
org.apache.pdfbox:pdfbox:1.8.2

This is wrong for “poi” because the group is missing (org.apache.poi). In the artifactory UI, both package have the same kind of pattern so I assume it is correct also for poi.

Artifact;Path;Repository
poi-3.14-sources.jar;org/apache/poi/poi/3.14;jcenter-cache
poi-3.14.jar;org/apache/poi/poi/3.14;jcenter-cache
poi-3.14.pom;org/apache/poi/poi/3.14;jcenter-cache
pdfbox-1.8.2-sources.jar;org/apache/pdfbox/pdfbox/1.8.2;jcenter-cache
pdfbox-1.8.2.jar;org/apache/pdfbox/pdfbox/1.8.2;jcenter-cache
pdfbox-1.8.2.pom;org/apache/pdfbox/pdfbox/1.8.2;jcenter-cache

I assume that the dependency “poi” cannot be retrieved because the group:package:version is not correct but I don’t know what causes that. Any idea ?

Thank you.