Setting up a C++ project

Hi guys
I try to set up a C++ project for windows, and get some unexpected problems.

At my first try, I have just cygwin and MinGW installed, a gcc --version returned with the expected version information, gpp did also.
But if I tried gradle run command after the init process, gradle states that there is no gcc compiler.

The next try with the native build plugin was also successless.

I also read about to set up a C++ project with Visual Studio plugin, so I installed VS but found no gradle related plugin.

Today I did the next try and initialized a C++ project with gradle again. Now I do not get a message about missed gcc, and get a green build successful message after a gradle run command. But there is nothing in the build/exe-directory, except a folder test. I expected also to see “Hellow World” standard phrase in the power shell prompt, but I don’t get it.

Does anyone have an idea?

I would recommend you have a look at

I also tried this.

I tried it now again. I have no idea what I do different the last time, but now I get an executable. Unfortunately, I see only a window which appears immediatly, even I start it from powershell and command prompt.
Is there an other way to run a programm without closing immediatly?

Sorry for that late reply, I get it now running.

As I said before, I have no idea why it doesn’t work on my first try. I also have no idea why my simple Hello-World-Window expires immediatly after the program is finished, but as I just want to verify that my gradle stuff runs properly, I have now what I need. After some days, I work on it again, just simply added a user input request (dirty hack, I know…).

The nokee-plugin and gradle makes it easy, very good tools.

1 Like