publishPlugins prepends text on the groupID

When I run a publishPlugins task it is generating a pom with incorrect data.

I have the following config:

pluginBundle {
    website = ''
    vcsUrl = ''
    tags = ['utility', 'syntastic']
    plugins {
        syntasticPlugin {
            id = 'com.scuilion.syntastic'
            displayName = 'Syntastic'
            description = 'Integrate syntastic with your gradle projects.'

When I run gradle publishPlugins it generates the pom under publish-generated-resources as follows:

<?xml version="1.0" encoding="UTF-8"?>  
<project xsi:schemaLocation="" xmlns="" xmlns:xsi="">

Notice how the groupId has “gradle.plugin” added to the beginning.


If you look at the bintray published pom it has the correct groupId

You can also see how it translates to the classpath in the plugins repo:

I feel like I’m missing something simple but just can’t seem to figure it out.


Hi Kevin

Thanks for the question.

You need to add a mavenCoordinates { } block as described on the full example tab of the documentation

Please let us know how you go.



Thanks this worked for me!