Plugin net.linguica.maven-settings version 0.4 missing

We have a software installation tool that is based upon gradle and the build depends on the version 0.4 of the net.linguica.maven-settings plugin to perform its tasks (it accesses our Nexus server to get the artefacts that made up our software). It worked fine up to now, when we are using the tool to install our software to a new server. The version 0.4 of the plugin net.linguica.maven-settings has disappeared from!
Our last use of the installation tool was October 21 and the plugin version 0.4 was at this date available.

Is there any reason the net.linguica.maven-settings 0.4 is no more available?
Is it possible to have this version of the plugin available in

The artifact seems to be there, so if you explicitly depend on version ‘0.4’ it’ll work. If you are doing something like 'net.linguica.gradle:maven-settings-plugin:+' you will be limited to version 0.3. It simply looks as though the Maven repo metadata is corrupted somehow. I’ll see about potentially republishing to fix this.

The dependency on version 0.4 is explicitly specified but strangely it didn’t work. Today, after a new attempt, indeed, it has worked as expected: maven-settings-plugin version 0.4 was found.
Thank for your help.