Plugin [id: 'org.gradle.kotlin.kotlin-dsl', version: '2.3.3'] was not found in any of the following sources:

I got the following exception when developing in IntelliJ:

Exception is:
org.gradle.api.plugins.UnknownPluginException: Plugin [id: 'org.gradle.kotlin.kotlin-dsl', version: '2.3.3'] was not found in any of the following sources:

Gradle Core Plugins (plugin is not in 'org.gradle' namespace)
Included Builds (None of the included builds contain this plugin)
Plugin Repositories (could not resolve plugin artifact 'org.gradle.kotlin.kotlin-dsl:org.gradle.kotlin.kotlin-dsl.gradle.plugin:2.3.3')
Searched in the following repositories:
Gradle Central Plugin Repository

I tried the following troubleshooting steps:

  • I updated to the latest version of Gradle 7.5.1.
  • I ran gradlew clean build -x test --refresh-dependencies
  • Created a new project
  • Verified that my gradle.properties and init.gradle.kts are in my user folder

What else can I try?

1 Like

I helped Chase try it without any init or properties files, just running straight defaults, and it still couldn’t find it. Tried running a build scan but it couldn’t find the plugin for that either. So maybe it’s unable to resolve any plugins?

1 Like

I ended up restoring to default settings in IntelliJ by going to FileManage IDE SettingsRestore Default Settings... . I now get a successful Gradle build. I noticed this message below after restoring. I am not sure if it relates to my question.
image

Hi, I’ve started receiving same error to the same plugin version, however resetting settings in IDEA didn’t work. Also it’s reproducer even in plain gradlew invocation in console.

Given that you also get the same “searched in” repositories,
then you probably have some firewall or anti-virus blocking the access,
or need to use some proxy for internet access that you didn’t configure for Gradle execution.

I had this same issue. Gradle was for some reason in Offline Mode so it was unable to acquire the plugin. Disabling Offline Mode fixed my problem.

1 Like