Parent pom is available in the Different repo

Hello All,

I want to download a zip file( as a maven dependency. Dependency is available in the artifactory maven repo.

Respective Dependency artifacts pom is dependent on other 2 pom files. & File3.pom -----> File2.pom------->File1.pom

Above is the sample description of the dependency.

Issue is :, File3.pom and File2.pom is available under same repo. But File1.pom is available in the different repo.

So, i cant able to download the dependency, I am getting the error like

Content is not allowed in prolog.

I have tried to add multiple maven repo under the repositories, as well i tried to add “artifactsurl”. Both are not working.

Can you please suggest the solve to overcome this issue.

To me that error says that Gradle might be trying to parse corrupt xml/pom files. Try building with a fresh Gradle cache mv ~/.gradle ~/.gradle.old. If you still get the same error, I would double check the xml content being returned from the repository.

@Chris_Dore - Thank you so much for your prompt response.

My old version of build engine is ANT, same dependency is working fine in ANT as a maven dependency.

But, its not working only with Gradle.

Is there anyway to redirect the parent pom search to different repo instead of main repo which contain dependency artifacts.

Can you share your current gradle config?

Content is not allowed in prolog

This message means that a process is trying to parse a file as xml, but the file is not valid xml