Not able to make Gradle work with Proxy using SPNEGO Kerberos


(Kiran Marturu) #1

Gradle Version: 4.6
OS: Windows 7 32-bit

I’m behind Proxy which is using Kerberos for authentication. I have set the below properties in gradle.properties

systemProp.javax.security.auth.useSubjectCredsOnly=false
systemProp.http.proxyHost={proxy-host}
systemProp.http.proxyPort={proxy-port}
systemProp.http.proxyUser={user-id}
systemProp.http.proxyPassword={password}
systemProp.http.nonProxyHosts=*.nonproxyrepos.com|localhost

But, it doesn’t work and below is run gradle with --debug

gradle --debug

I see from the --debug that it is trying to use NTLM insted of NEGOTIATE

I think Gradle is using Apache HTTP Client. And I tried to create a small code using HTTPClient and I’m able to make it work

I tried setting HTTPClient logging options. But, unable get any RAW HTTP Request/Response for tracing.

systemProp.org.apache.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog
systemProp.org.apache.commons.logging.simplelog.showdatetime=true
systemProp.org.apache.commons.logging.simplelog.log.org.apache.http=DEBUG
systemProp.org.apache.commons.logging.simplelog.log.org.apache.http.wire=ERROR
systemProp.org.apache.commons.logging.simplelog.log.org.apache.http.impl.conn=DEBUG
systemProp.org.apache.commons.logging.simplelog.log.org.apache.http.impl.client=DEBUG
systemProp.org.apache.commons.logging.simplelog.log.org.apache.http.client=DEBUG

Anyone can guide me how to solve the issue.


(Kiran Marturu) #2

My bad, solved with adding https proxy :sweat_smile: