Nativescript-Vue: Gradle could not extract native JNI library

Hellow everyone,
I am trying to learn Nativescript-Vue and I followed all the instructions on how to get started. After a little while, I was able to create my first project but I coudn’t run it into the emulator.

I just want to know why Gradle could not extract native JNI library everytime I run $ tns run android --bundle.

I already have my environment setup properly. I run $ tns doctor and there are no issues. I installed Android Studio so I could use its emulator.

Specifically, I get something like this

FAILURE: Build failed with an exception.

  • What went wrong:
    Could not extract native JNI library.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at
    Unable to apply changes on device: emulator-5554. Error is: Command gradlew.bat failed with exit code 1.

I’m really confused to why this is happening. Please help me.