Maven Publish Plugin stopped honoring the local maven repository location


(Martin Göllnitz) #1

I just moved from gradle 1.8 to gradle 1.10. Can it be that the publish maven plugin does not honor my local maven repository location setting (anymore)? The usual

gradle clean publishToMavenLocal

put the stuff in my home directory’s .m2/ instead of the my local maven repository as stated in the default settings.xml (which of course is located in my home directory’s -m2/)

I so far didn’t find any migration issues for that part. (In fact I didn’t see anything why Java developers should move away from 1.8, but my netbeans IDE kept whining about the 1.8 version of gradle for some reason)


(Luke Daley) #2

I’m not clear on what you’re saying here.

After upgrading, is Gradle not respecting a custom local maven repository location that is defined in your settings.xml? Where is your settings.xml file located?


(Martin Göllnitz) #3

Yes, exactly that - and the settings.xml is in the default location im my home directory’s .m2 subdirectory. So the only change I did was to change gradle from 1.8 to 1.10.


(Luke Daley) #4

This is something that we test quite extensively: https://github.com/gradle/gradle/blob/master/subprojects/core-impl/src/integTest/groovy/org/gradle/integtests/resolve/maven/MavenLocalRepoResolveIntegrationTest.groovy

Can you think of any other factor that might be at play here, that we aren’t testing for?


(Luke Daley) #5

Ah, I see it’s on the publish side now. Ignore my comment above.


(Martin Göllnitz) #6

Up to now I have no idea - and I’m pretty sure that I didn’t change anything except the version update of gradle. Also I’m using the new maven publish plugin because there are only very few things I had to configure.

If you want to bother, you are invited to look at any code line in

https://github.com/mgoellnitz/tangram

The publishing part is - with one exception you really can ignore - concentrated in lib.gradle for mere jars and webapp.gradle for webapps - all the common rest is in commons.gradle where the plugin gets applied.

I have an M2_HOME pointing to some maven 3 and my gradle_home points to some non default location. All of these happily unchanged since the days of gradle 1.6.

I’m quite sure that the repository location gets read from my settings.xml when resolving dependencies.


(Luke Daley) #7

I’ve found the cause and pushing a fix. This will be fixed in 1.11.

There’s no known workaround before then I’m afraid.


(Martin Göllnitz) #8

The main thing: I’ll stop looking for a problem on my side and we all know about it. Thanks so much! I’ll stick to my old 1.8 for the time being.


(blackbeltdev) #9

What’s the status on this? I see the bug is still open after 1.11 was released.