Long warning message when using org.gradle.jvmargs


(kiran_anantha) #1

Hello, I am using org.gradle.jvmargs in my project/gradle.properties to specify the memory needed to build. I am not specifying the daemon flags since I don’t want the CI machine which will use the same build.gradle/gradle.proeprties to use the daemon.

But I see this long warning message - is there any way to turn it off?

Note: in order to honour the org.gradle.jvmargs and/or org.gradle.java.home values specified for this build, it is nec To avoid the slowdown associated with this extra process, you might want to consider running Gradle with the daemon en Please see the user guide chapter on the daemon at http://gradle.org/docs/1.4/userguide/gradle_daemon.html.


(Szczepan Faber) #2

I agree it should not be a warning. Warnings work best if the user can immediately fix them by changing the build script / settings. In this case you don’t want to run with the daemon so you have to see this warning with every build.

How about we lower the log level to lifecycle and tweak the message so that it’s more succinct?

Cheers!


#3

Since Gradle cannot change the vm args of the running VM, it needs to launch a ‘daemon’ process to host your build. So you are actually using a short-lived daemon without explicitly requesting it. Hence the warning.

The best way to remove this warning is to ensure that the VM that launches gradle already has the jvm args specified: you could possibly do this by hacking the launcher script that starts Gradle.