Java Quickstart problems


(keith_hyland) #1

I am just getting started with Gradle. I am trying to run the java quickstart example but it is failing claiming that it can’t find a system java compiler.

I have a JDK on my system path, and my JAVA_HOME is pointing correctly to that dir. See below.

I’ve also tried runnign this with gradle 1.4, but get the same error.

Any ideas

C:\apps\gradle-1.3\samples\java\quickstart>echo %JAVA_HOME% C:\apps\Java\jdk1.6.0_29

C:\apps\gradle-1.3\samples\java\quickstart>gradle build :compileJava FAILED

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ‘:compileJava’. > Cannot find System Java Compiler. Ensure that you have installed a JDK (not ju st a JRE) and configured your JAVA_HOME system variable to point to the accordin g directory.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 10.56 secs

Logs when run with --debug C:\apps\gradle-1.3\samples\java\quickstart>gradle build --debug 14:12:38.815 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:39.949 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:39.956 [INFO] [org.gradle.BuildLogger] Starting Build 14:12:39.957 [DEBUG] [org.gradle.BuildLogger] Gradle user home: C:\Users\a507823 .gradle 14:12:39.958 [DEBUG] [org.gradle.BuildLogger] Current dir: C:\apps\gradle-1.3\sa mples\java\quickstart 14:12:39.961 [DEBUG] [org.gradle.BuildLogger] Settings file: null 14:12:39.962 [DEBUG] [org.gradle.BuildLogger] Build file: null 14:12:39.980 [DEBUG] [org.gradle.initialization.BuildSourceBuilder] Starting to build the build sources. 14:12:40.010 [DEBUG] [org.gradle.initialization.BuildSourceBuilder] Gradle sourc e dir does not exist. We leave. 14:12:40.036 [DEBUG] [org.gradle.initialization.DefaultGradlePropertiesLoader] F ound env project properties: [] 14:12:40.062 [DEBUG] [org.gradle.initialization.DefaultGradlePropertiesLoader] F ound system project properties: [] 14:12:40.336 [DEBUG] [org.gradle.api.internal.artifacts.mvnsettings.DefaultLocal MavenRepositoryLocator

]

N o local repository in Settings file defined. Using default path: C:\Users\a50782 3.m2\repository 14:12:40.820 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:40.864 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:40.882 [DEBUG] [org.gradle.initialization.ScriptEvaluatingSettingsProcesso r

]

T iming: Processing settings took: 0.799 secs 14:12:40.911 [INFO] [org.gradle.BuildLogger] Settings evaluated using empty sett ings script. 14:12:41.094 [DEBUG] [org.gradle.initialization.ProjectPropertySettingBuildLoade r

]

L ooking for project properties from: C:\apps\gradle-1.3\samples\java\quickstart\g radle.properties 14:12:41.152 [DEBUG] [org.gradle.initialization.ProjectPropertySettingBuildLoade r

]

p roject property file does not exists. We continue! 14:12:41.206 [INFO] [org.gradle.BuildLogger] Projects loaded. Root project using

build file ‘C:\apps\gradle-1.3\samples\java\quickstart\build.gradle’. 14:12:41.271 [INFO] [org.gradle.BuildLogger] Included projects: [root project ‘q uickstart’] 14:12:41.295 [INFO] [org.gradle.configuration.BuildScriptProcessor] Evaluating r oot project ‘quickstart’ using build file ‘C:\apps\gradle-1.3\samples\java\quick start\build.gradle’. 14:12:41.342 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire shared lock on buildscript class cache for build file ‘C:\apps\gradle -1.3\samples\java\quickstart\build.gradle’ (C:\Users\a507823.gradle\caches\1.3\ scripts\build_3olildeophk9kn54c4shj3e13v\ProjectScript\buildscript). 14:12:41.396 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acq uired. 14:12:41.431 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:41.455 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire shared lock on no_buildscript class cache for build file ‘C:\apps\gra dle-1.3\samples\java\quickstart\build.gradle’ (C:\Users\a507823.gradle\caches\1 .3\scripts\build_3olildeophk9kn54c4shj3e13v\ProjectScript\no_buildscript). 14:12:41.488 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acq uired. 14:12:43.329 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Fini shed configuring with level: DEBUG, configurers: [org.gradle.logging.internal.Ou tputEventRenderer@76f8968f, org.gradle.logging.internal.logback.LogbackLoggingCo nfigurer@3a64c34e, org.gradle.logging.internal.JavaUtilLoggingConfigurer@2d5253d 5] 14:12:43.643 [DEBUG] [org.gradle.configuration.BuildScriptProcessor] Timing: Run ning the build script took 2.315 secs 14:12:43.872 [INFO] [org.gradle.BuildLogger] All projects evaluated. 14:12:44.357 [DEBUG] [org.gradle.execution.taskgraph.DefaultTaskGraphExecuter] T iming: Creating the DAG took 0.259 secs 14:12:44.582 [INFO] [org.gradle.execution.TaskNameResolvingBuildConfigurationAct ion

]

S elected primary task ‘build’ 14:12:44.625 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire exclusive lock on task artifact state cache (C:\apps\gradle-1.3\sampl es\java\quickstart.gradle\1.3\taskArtifacts). 14:12:44.921 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acq uired. 14:12:45.063 [INFO] [org.gradle.BuildLogger] Tasks to be executed: [task ‘:compi leJava’, task ‘:processResources’, task ‘:classes’, task ‘:jar’, task ':assemble ', task ‘:compileTestJava’, task ‘:processTestResources’, task ‘:testClasses’, t ask ‘:test’, task ‘:check’, task ‘:build’] 14:12:45.097 [LIFECYCLE] [org.gradle.TaskExecutionLogger] :compileJava 14:12:45.109 [DEBUG] [org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceT askExecuter

]

S tarting to execute task ‘:compileJava’ 14:12:45.230 [DEBUG] [org.gradle.api.internal.tasks.execution.SkipUpToDateTaskEx ecuter

]

D etermining if task ‘:compileJava’ is up-to-date 14:12:45.335 [DEBUG] [org.gradle.cache.internal.btree.BTreePersistentIndexedCach e

]

O pening cache taskArtifacts.bin (C:\apps\gradle-1.3\samples\java\quickstart.grad le\1.3\taskArtifacts\taskArtifacts.bin) 14:12:45.518 [DEBUG] [org.gradle.api.internal.changedetection.DefaultFileCacheLi stener

]

C an cache files for configuration ‘:compile’ 14:12:45.600 [DEBUG] [org.gradle.api.internal.changedetection.DefaultFileCacheLi stener

]

C an cache files for directory ‘C:\apps\gradle-1.3\samples\java\quickstart\src\mai n\java’ 14:12:45.680 [DEBUG] [org.gradle.api.internal.changedetection.DefaultFileCacheLi stener

]

C an cache files for file ‘C:\apps\gradle-1.3\samples\java\quickstart\build\classe s\main’ 14:12:45.723 [DEBUG] [org.gradle.api.internal.changedetection.DefaultFileCacheLi stener

]

C an cache files for file ‘C:\apps\gradle-1.3\samples\java\quickstart\build\depend ency-cache’ 14:12:45.746 [DEBUG] [org.gradle.cache.internal.btree.BTreePersistentIndexedCach e

]

O pening cache outputFileStates.bin (C:\apps\gradle-1.3\samples\java\quickstart.g radle\1.3\taskArtifacts\outputFileStates.bin) 14:12:45.814 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Waiting to acquire exclusive lock on artifact cache (C:\Users\a507823.gradle\caches\art ifacts-15). 14:12:45.871 [DEBUG] [org.gradle.cache.internal.DefaultFileLockManager] Lock acq uired. 14:12:45.925 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.resolveengine .DefaultDependencyResolver

]

R esolving configuration ‘:compile’ 14:12:46.114 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘ivy.default.settings.dir’ to ‘jar:file:/C:/apps/gradle-1.3/lib/ivy-2.2.0 .jar!/org/apache/ivy/core/settings’ 14:12:46.130 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘ivy.basedir’ to ‘C:\apps\gradle-1.3\samples\java\quickstart.’ 14:12:46.143 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘ivy.default.conf.dir’ to ‘jar:file:/C:/apps/gradle-1.3/lib/ivy-2.2.0.jar !/org/apache/ivy/core/settings’ 14:12:46.206 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.runtime.name’ to ‘Java™ SE Runtime Environment’ 14:12:46.221 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.boot.library.path’ to ‘C:\apps\Java\jdk1.6.0_34\jre6\bin’ 14:12:46.264 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.version’ to ‘20.9-b04’ 14:12:46.284 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.vendor’ to ‘Sun Microsystems Inc.’ 14:12:46.296 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vendor.url’ to ‘http://java.sun.com/’ 14:12:46.310 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘path.separator’ to ‘;’ 14:12:46.345 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.name’ to ‘Java HotSpot™ 64-Bit Server VM’ 14:12:46.362 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘file.encoding.pkg’ to ‘sun.io’ 14:12:46.373 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.country’ to ‘IE’ 14:12:46.385 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.java.launcher’ to ‘SUN_STANDARD’ 14:12:46.403 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.os.patch.level’ to ‘Service Pack 1’ 14:12:46.421 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.specification.name’ to ‘Java Virtual Machine Specification’ 14:12:46.438 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.dir’ to ‘C:\apps\gradle-1.3\samples\java\quickstart’ 14:12:46.458 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.runtime.version’ to ‘1.6.0_34-b04’ 14:12:46.474 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.awt.graphicsenv’ to ‘sun.awt.Win32GraphicsEnvironment’ 14:12:46.490 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.endorsed.dirs’ to ‘C:\apps\Java\jdk1.6.0_34\jre6\lib\endorsed’ 14:12:46.520 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘os.arch’ to ‘amd64’ 14:12:46.547 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.io.tmpdir’ to ‘C:\Users\a507823\AppData\Local\Temp’ 14:12:46.563 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘line.separator’ to ’ ’ 14:12:46.583 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘org.gradle.appname’ to ‘gradle’ 14:12:46.599 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.specification.vendor’ to ‘Sun Microsystems Inc.’ 14:12:46.621 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.variant’ to ‘’ 14:12:46.643 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘os.name’ to ‘Windows 7’ 14:12:46.656 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘jna.boot.library.path’ to ‘C:\Users\a507823.gradle\native\jna\win32-amd 64’ 14:12:46.672 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.jnu.encoding’ to ‘Cp1252’ 14:12:46.695 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘http.proxyPort’ to ‘8000’ 14:12:46.707 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.library.path’ to ‘C:\apps\Java\jdk1.6.0_29\bin;C:\Windows\Sun\Java\ bin;C:\Windows\system32;C:\Windows;C:\apps\oraclexe\app\oracle\product\11.2.0\se rver\bin;;C:\apps\Java\jdk1.6.0_29\bin;C:\apps\grails-1.3.5\bin;C:\apps\groovy-1 .8.5\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\Syst em32\WindowsPowerShell\v1.0;C:\Program Files\Intel\WiFi\bin;C:\Program Files\C ommon Files\Intel\WirelessCommon;C:\Program Files (x86)\Enterprise Vault\EVClie nt;C:\Program Files (x86)\Microsoft Office 2010\Office14;C:\Program Files\Torto iseSVN\bin;c:\apps;C:\apps\GnuPG\pub;C:\Program Files\TortoiseHg;C:\Program Fil es (x86)\sbt;C:\Program Files (x86)\giter8;C:\Program Files (x86)\scala\bin;C :\Program Files\nodejs;C:\Program Files (x86)\Adobe\Reader 9.0\Reader;C:\Progr am Files (x86)\Adobe\Reader 9.0\Reader\plug_ins;C:\Program Files (x86)\Mozilla F irefox;C:\apps\Java\jdk1.6.0_29\bin;C:\apps\grails-1.3.5\bin;C:\apps\groovy-1.7. 10\bin;C:\apps\oraclexe\app\oracle\product\11.2.0\server\bin;C:\Windows\system32 ;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\ ;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCo mmon;C:\Program Files (x86)\Enterprise Vault\EVClient;C:\Program Files (x86)\M icrosoft Office 2010\Office14;C:\Program Files\TortoiseSVN\bin;c:\apps;C:\Progra m Files (x86)\Adobe\Reader 9.0\Reader\plug_ins\test_tools;C:\apps\Git\cmd;c:\app s\apache-ant-1.8.2\bin;C:\apps\gradle-1.3\bin;C:\apps\apache-maven-3.0.4\bin;C:\ appsMercurial;C:\apps\mongodb-win32-x86_64-2008plus-2.0.6\bin;C:\Python27;C:\Pyt hon27\DLLs;C:\Python27\Scripts;C:\Users\a507823\AppData\Roaming\npm;C:\Program Files\MySQL\MySQL Server 5.6\bin;.’ 14:12:46.723 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.class.version’ to ‘50.0’ 14:12:46.741 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.specification.name’ to ‘Java Platform API Specification’ 14:12:46.752 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.management.compiler’ to ‘HotSpot 64-Bit Tiered Compilers’ 14:12:46.764 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘os.version’ to ‘6.1’ 14:12:46.779 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.home’ to ‘C:\Users\a507823’ 14:12:46.794 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.timezone’ to ‘Europe/London’ 14:12:46.803 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.awt.printerjob’ to ‘sun.awt.windows.WPrinterJob’ 14:12:46.816 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.specification.version’ to ‘1.6’ 14:12:46.829 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘file.encoding’ to ‘Cp1252’ 14:12:46.845 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.name’ to ‘a507823’ 14:12:46.857 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.class.path’ to ‘C:\apps\gradle-1.3\bin…\lib\gradle-launcher-1.3.j ar’ 14:12:46.871 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.specification.version’ to ‘1.0’ 14:12:46.880 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.arch.data.model’ to ‘64’ 14:12:46.891 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.java.command’ to ‘org.gradle.launcher.GradleMain build --debug’ 14:12:46.904 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.home’ to ‘C:\apps\Java\jdk1.6.0_34\jre6’ 14:12:46.916 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.specification.vendor’ to ‘Sun Microsystems Inc.’ 14:12:46.927 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘user.language’ to ‘en’ 14:12:46.948 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘awt.toolkit’ to ‘sun.awt.windows.WToolkit’ 14:12:46.964 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vm.info’ to ‘mixed mode’ 14:12:46.976 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.version’ to ‘1.6.0_34’ 14:12:46.987 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.ext.dirs’ to ‘C:\apps\Java\jdk1.6.0_34\jre6\lib\ext;C:\Windows\Sun\ Java\lib\ext’ 14:12:46.998 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘http.proxyHost’ to ‘http.proxy.fmr.com’ 14:12:47.008 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.boot.class.path’ to ‘C:\apps\Java\jdk1.6.0_34\jre6\lib\resources.jar ;C:\apps\Java\jdk1.6.0_34\jre6\lib\rt.jar;C:\apps\Java\jdk1.6.0_34\jre6\lib\sunr sasign.jar;C:\apps\Java\jdk1.6.0_34\jre6\lib\jsse.jar;C:\apps\Java\jdk1.6.0_34\j re6\lib\jce.jar;C:\apps\Java\jdk1.6.0_34\jre6\lib\charsets.jar;C:\apps\Java\jdk1 .6.0_34\jre6\lib\modules\jdk.boot.jar;C:\apps\Java\jdk1.6.0_34\jre6\classes’ 14:12:47.025 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vendor’ to ‘Sun Microsystems Inc.’ 14:12:47.041 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘file.separator’ to ‘’ 14:12:47.054 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘java.vendor.url.bug’ to ‘http://java.sun.com/cgi-bin/bugreport.cgi’ 14:12:47.081 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.io.unicode.encoding’ to ‘UnicodeLittle’ 14:12:47.117 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.cpu.endian’ to ‘little’ 14:12:47.141 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.desktop’ to ‘windows’ 14:12:47.152 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘sun.cpu.isalist’ to ‘amd64’ 14:12:47.164 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘ivy.cache.dir’ to ‘C:\Users\a507823.gradle\caches\artifacts-15\ivy’ 14:12:47.177 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.IvyLoggingAda per

]

s etting ‘ivy.log.modules.in.use’ to ‘false’ 14:12:47.251 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.resolveengine .DependencyGraphBuilder

]

V isiting configuration #quickstart;1.0(compile). 14:12:47.269 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.resolveengine .DependencyGraphBuilder

]

V isiting dependency #quickstart;1.0(compile) -> commons-collections#commons-colle ctions;3.2([default]) 14:12:47.290 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.resolveengine .DependencyGraphBuilder

]

S electing new module version commons-collections#commons-collections;3.2 14:12:47.305 [DEBUG] [org.gradle.api.internal.artifacts.ivyservice.ivyresolve.Us erResolverChain

]


#2

Please post the output of ‘gradle -v’


(keith_hyland) #3

Hmm something strange is going on alright gradle is picking up a different JRE

gradle -v ------------------------------------------------------------ Gradle 1.4 ------------------------------------------------------------

Gradle build time: 28 January 2013 03:42:46 o’clock UTC Groovy: 1.8.6 Ant: Apache Ant™ version 1.8.4 compiled on May 22 2012 Ivy: 2.2.0 JVM: 1.6.0_34 (Sun Microsystems Inc. 20.9-b04) OS: Windows 7 6.1 amd64

Java picks up the same version, but javac picks up the JAVA_HOME version

C:\apps\Java\jdk1.6.0_29\bin>.\java -version java version “1.6.0_34” Java™ SE Runtime Environment (build 1.6.0_34-b04) Java HotSpot™ 64-Bit Server VM (build 20.9-b04, mixed mode)

C:\apps\Java\jdk1.6.0_29\bin>.\javac -version javac 1.6.0_29

my PATH variable has the JDK first in the path


(keith_hyland) #4

Ok so uninstalling some rogue JRE’s, updating my system variables, and a restart sorted out my problems.

Thanks for the help


(Dan Funk) #5

For those wondering how to accomplish Keith’s solution on Ubuntu, you can install the JDK package with the following: > sudo aptitude install openjdk-7-jdk

I found myself in this position because I was running JRE as a package, and had downloaded the JDK and set it using the JAVA_HOME. Which worked fine till I went to use gradle.

I figured out what was wrong by using

sudo update-java-alternatives -l

Which lists what java versions are installed on Ubuntu. I can now easily swtich to a different version universally by running update-java-alternatives with one of the items in the list from the above command, such as … > sudo update-java-alternatives -s java-1.7.0-openjdk-amd64


(Kevin O'Neal) #6

You solved my problem only a day before I needed it. Thanks!


(jolien.coenraets) #7

Setting the variable, restart the server & executing the android clean task did the thing :-).