Is the wrapper task _not_ available by default?

I had an odd surprise today where we had a precompiled script plugin like this:

plugins {

// Other config would follow here

The plugin in question is one of the ones here, and I can see from their code that the failure is when it tries to lookup the “wrapper” task, which apparently does not exist in the project.

I have initially filed the ticket with them on the basis that there is probably a plugin they have to apply before looking up the task, but as I think more about it, the “wrapper” task is one which I thought was just always there by default.

Is that not the case after all? The docs for the wrapper task certainly seem to imply that it’s built-in.

I think it is always available.
But maybe it is not on the dummy project that is used for generating type-safe accessors as that is where it fails in that issue you opened.

I’d recommend you open an issue with Gradle about this on GitHub.

As a work-around you (or that plugin) could apply the wrapper plugin manually I guess.

Indeed that workaround is working. I thought I had tried it already with no luck… but it worked today.

Will open a Gradle ticket about it.