Is the gradleApi() dependency call broken in M5? [GRADLE-1699]


(Matias Bjarland) #1

I found the following JIRA on the subject:

http://issues.gradle.org/browse/GRADLE-1699?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

As the ticket is closed and the fix version is set to 1.0-milestone-5 I figured this would be fixed. However when I run a build in my plugin project I get a failure to resolve a gradle class:

...
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
.../build/core/ConvenienceOperations.groovy: 25: unable to resolve class org.gradle.api.internal.file.BaseDirConverter
 @ line 25, column 1.
   import org.gradle.api.internal.file.BaseDirConverter
   ^
  1 error
...

This is trying to compile some groovy code for my custom plugin. The dependency closure looks as follows:

dependencies {
  groovy
    gradleApi(),
              'org.slf4j:slf4j-nop:1.6.1'
  testCompile 'org.spockframework:spock-core:0.5-groovy-1.7'
}

I also tried to use the workaround mentioned in the jira, but no luck. Either I’m missing something (likely) here or the ticket is not closed yet (less so).

Output from “gradle --version”:

  ------------------------------------------------------------  Gradle 1.0-milestone-5  ------------------------------------------------------------

 Gradle build time: Tuesday, October 25, 2011 5:56:08 AM CEST  Groovy: 1.7.10  Ant: Apache Ant(TM) version 1.8.2 compiled on December 20 2010  Ivy: 2.2.0  JVM: 1.6.0_26 (Apple Inc. 20.1-b02-383)  OS: Mac OS X 10.7.2 x86_64  

Any help much appreciated.


(Matias Bjarland) #2

I reverted back to 1.0-milestone-3 and the issue went away so my immediate problem is solved.

Still leaves this issue with M5 open.


(Matias Bjarland) #3

Is this issue fixed in the new M5 snapshot released today?


(Matias Bjarland) #4

To close this issue and for people who might be running into this: I can confirm that with the latest version of the 1.0-milestone-5 release (I think it was built the 25th), this is no longer an issue.

So the issue was closed in M5, just in a later snapshot of M5 than what I was running when I first posted this.


(Luke Daley) #5

Thanks for posting back the resolution Matias :slight_smile: