Installation issue


(Igor Meltser) #1

Hi,

I am trying to install gradle on openSuse. I followed the instructions, unzip, added bin folder to path, but when I run gradle I get:

:~> gradle

FAILURE: Build aborted because of an internal error.

  • What went wrong: Build aborted because of an unexpected internal error. Please file an issue at: http://forums.gradle.org.

  • Try:

Run with --debug option to get additional debug info.

  • Exception is: net.rubygrapefruit.platform.NativeException: Could not open terminal for stdout: could not get termcap entry

at net.rubygrapefruit.platform.internal.TerminfoTerminal.init(TerminfoTerminal.java:49)

at net.rubygrapefruit.platform.internal.WrapperTerminal.init(WrapperTerminal.java:41)

at net.rubygrapefruit.platform.internal.AbstractTerminals.getTerminal(AbstractTerminals.java:35)

at org.gradle.internal.nativeplatform.console.NativePlatformConsoleDetector.getConsole(NativePlatformConsoleDetector.java:42)

at org.gradle.logging.internal.ConsoleConfigureAction.execute(ConsoleConfigureAction.java:32)

at org.gradle.logging.internal.ConsoleConfigureAction.execute(ConsoleConfigureAction.java:27)

at org.gradle.logging.internal.OutputEventRenderer.attachConsole(OutputEventRenderer.java:68)

at org.gradle.logging.internal.DefaultLoggingManager.attachConsole(DefaultLoggingManager.java:149)

at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:168)

at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:139)

at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:33)

at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:22)

at org.gradle.launcher.Main.doAction(Main.java:48)

at org.gradle.launcher.bootstrap.EntryPoint.run(EntryPoint.java:45)

at org.gradle.launcher.Main.main(Main.java:39)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at org.gradle.launcher.bootstrap.ProcessBootstrap.runNoExit(ProcessBootstrap.java:50)

at org.gradle.launcher.bootstrap.ProcessBootstrap.run(ProcessBootstrap.java:32)

at org.gradle.launcher.GradleMain.main(GradleMain.java:26)

Any advice?


(Luke Daley) #2

This looks like a bug in the native capability detection. I’ve raised GRADLE-2782.

In the meantime, you can try disabling it by setting the env var ‘GRADLE_OPTS’:

export GRADLE_OPTS=-Dorg.gradle.native=false


(Igor Meltser) #3

Thanks, it worked.


(Adam Murdoch) #4

Can you provide the output of ‘gradle -v’?


(Igor Meltser) #5

------------------------------------------------------------ Gradle 1.6 ------------------------------------------------------------

Gradle build time: Tuesday, May 7, 2013 9:12:14 AM UTC Groovy: 1.8.6 Ant: Apache Ant™ version 1.8.4 compiled on May 22 2012 Ivy: 2.2.0 JVM: 1.7.0_17 (Oracle Corporation 23.7-b01) OS: Linux 3.4.63-2.44-desktop amd64


(Adam Murdoch) #6

Thanks. What’s your $TERM environment variable set to?


(Igor Meltser) #7

TERM=xterm