Install Gradle, Unable to Access jettyRun

I’m now trying to get the cardiac risk app to work.

Looked at the read-me above. I started by installing gradle from the site and moving the folder to my Users/usr/local.

I add Gradle to my PATH variable: export PATH=/usr/local/gradle/gradle-2.7/bin:$PATH
Ran gradle –version to verify that it was installed.
I then return to the directory with the cardiac-risk-app clone. I create a new file called build.gradle which contains this line

apply plugin: 'jetty'

as shown on gradle’s documentation (

I’ve tried many which ways but am not able to actually get jetty working. When I’m in the cardiac-risk-app directory and type in

gradle jettyrun 

I receive the following error

Nimbus:cardiac-risk-app pae2$ gradle jettyrun

:compileJava UP-TO-DATE 

:processResources UP-TO-DATE 

:classes UP-TO-DATE 

:jettyRun FAILED 

FAILURE: Build failed with an exception. 

* What went wrong: 

A problem was found with the configuration of task ':jettyRun'. 

> Directory '/Users/pae2/cardiac-risk-app/src/main/webapp' specified for property 'webAppSourceDirectory' does not exist. 

* Try: 

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. 


Total time: 4.095 secs

I’m completely new to Gradle. I’ve tried to review stackexchange and the Gradle forum but have not seen anything that’s been able to rectify it. When I review tasks available in gradle jetty does not show up at all.

Things I’m wondering that I might be doing wrong:

  1. I’ve installed Gradle to usr/local rather than the working git directory. Must it be installed directly there?
  2. I’ve created a basic txt file in sublime called build.gradle, located in the working git directory, with that single line of apply plugin: 'jetty'. Does this require additional code or directing?

Greatly appreciate people’s thoughts on this!

I think there’s something missing from that project (a working build.gradle) or the readme is wrong and you’re supposed to use something else to serve the project.

Usually, for jetty, you’ll have a src/main/webapp directory that contains your CSS/JS/etc files. There’s usually Java code too. Since the readme is so old, it makes me think the documentation is just wrong.