htmlDependencyReport generation task failed in Gradle 1.10


(Anuruddika Mahanama) #1

I used Gradle 1.9 and generated htmlDependencyReport. But I upgraded Gradle to 1.10 (current latest) and then htmlDependencyReport gives following error.

“org.gradle.api.internal.artifacts.component.DefaultProjectComponentIdentifier cannot be cast to org.gradle.api.artifacts.component.ModuleComponentIdentifier”

How to resolve this?


(Benjamin Muschko) #2

Thanks for reporting this issue. I can reproduce it and it is definitely a bug.


(Anuruddika Mahanama) #3

Ok Thanks