How to prevent gradle to auto upgrade version

gradle-3297

(Kevin Peter) #1

I have grade dependencies with specific version. But The gradle doing auto upgrade to another psecific version. How can I stop this?

Below is my build.gradle code

// jetty
compile ('org.eclipse.jetty:jetty-client:9.2.19.v20160908'){
exclude group:'org.eclipse.jetty'
}
compile group: 'org.eclipse.jetty', name: 'jetty-util-ajax', version: '9.2.19.v20160908'
compile group: 'org.eclipse.jetty', name: 'jetty-util', version: '9.2.19.v20160908'
compile group: 'org.eclipse.jetty', name: 'jetty-io', version: '9.2.19.v20160908'
compile ('org.eclipse.jetty:jetty-http:9.2.19.v20160908'){force = true}

Below is the dependency tree.

— org.eclipse.jetty:jetty-client:9.2.19.v20160908 -> 9.3.14.v20161028
±-- org.eclipse.jetty:jetty-util-ajax:9.2.19.v20160908
| — org.eclipse.jetty:jetty-util:9.2.19.v20160908 -> 9.3.14.v20161028
±-- org.eclipse.jetty:jetty-util:9.2.19.v20160908 -> 9.3.14.v20161028
±-- org.eclipse.jetty:jetty-io:9.2.19.v20160908 -> 9.3.14.v20161028
| — org.eclipse.jetty:jetty-util:9.3.14.v20161028
±-- org.eclipse.jetty:jetty-http:9.2.19.v20160908 -> 9.3.14.v20161028
| — org.eclipse.jetty:jetty-util:9.3.14.v20161028