Help needed. Android aapt2 exception for mergeAlphaDebugResources slice 9 images

android

(FD) #1

After an upgrade of an Android project I have taken over, it no longer builds.

It always fails when trying to handle some 9-slice images.

I have tried with different versions of Gradle and I have tried with aapt (1) but always the same problem.
Some files from the same catalog seems to work.

Error from running task assembleDebug:

Task :app:createAlphaDebugCompatibleScreenManifests UP-TO-DATE
Task :app:processAlphaDebugManifest UP-TO-DATE
Task :app:fabricGenerateResourcesAlphaDebug
Task :app:generateAlphaDebugResValues UP-TO-DATE
Task :app:generateAlphaDebugResources UP-TO-DATE
Task :app:mergeAlphaDebugResources FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:mergeAlphaDebugResources’.

java.util.concurrent.ExecutionException: com.android.builder.internal.aapt.v2.Aapt2Exception: Android resource compilation failed
Output: error: .

Command: /Users/USER/.gradle/caches/transforms-1/files-1.1/aapt2-3.2.0-rc02-4818971-osx.jar/d1203620027a82a5c9784b5596bdb00e/aapt2-3.2.0-rc02-4818971-osx/aapt2 compile --legacy
-o
/Users/USER/WORK/PROJECT/app/build/intermediates/res/merged/alpha/debug
/Users/USER/WORK/PROJECT/app/src/main/res/drawable-mdpi/right_bubble_sha.9.png
Daemon: AAPT2 aapt2-3.2.0-rc02-4818971-osx Daemon #0

Any input?
Thanks