Gradle tutorial first example "hello" fails

I downloaded gradle “to a headless server” and unzipped it and added it to my path.

I created the “hello gradle” example from
and created a simple build file:
task hello {
doLast {
println ‘Hello Gradle’

I typed gradle hello and got an error. I tried some other things but nothing worked.

The error is this:
gradle --stacktrace hello
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon:
Daemon will be stopped at the end of the build stopping after processing
java.lang.NoClassDefFoundError: Could not initialize class org.codehaus.groovy.vmplugin.v7.Java7
at org.codehaus.groovy.vmplugin.VMPluginFactory.(
and many more lines.

The computer is a newly created instance at Digital Ocean running Debian Bullseye w/o a GUI.

I installed OpenJDK and included java in my path:

java -version
openjdk version “14-ea” 2020-03-17
OpenJDK Runtime Environment (build 14-ea+36-Debian-2)
OpenJDK 64-Bit Server VM (build 14-ea+36-Debian-2, mixed mode, sharing)

I downloaded gradle 6.2.2 and unzipped it and set my path accordingly.

I set my classpath to .

I am unable to make any progress.



found this:

JDK 14 support · Issue #10248 · gradle/gradle · GitHub › gradle › gradle › issues
Aug 9, 2019 - Downgrade java until Gradle 6.3 is released with a Groovy fix (gradle… …

I will attempt to upgrade.