Gradle not compiling classes


(Francois Ritaly) #1

I have a Gradle project which contains some java classes.

When I build thoses classes against a dependency in version A, the classes are properly compiled to the “build/classes” directory.

When I change the version of my dependency from A to B, Gradle stops compiling the classes. The “build/classes” directory is empty.

This issue happens with Gradle 2.14.1 and 3.2.1. I tried with older versions of Gradle, same issue.

I ran the compilation in debug but the log doesn’t provide any insight why the Java compiler doesn’t compile the classes.

When this issue happens, the log reads like below.

15:30:34.666 [INFO] [org.gradle.api.internal.tasks.compile.JdkJavaCompiler] Compiling with JDK Java compiler API.
15:30:35.035 [DEBUG] [org.gradle.cache.internal.btree.BTreePersistentIndexedCache] Opening cache fileSnapshotsToTreeSnapshotsIndex.bin (/Users/francois.ritaly/git/birt-engine-460/.gradle/2.14.1/taskArtifacts/fileSnapshotsToTreeSnapshotsIndex.bin)
15:30:35.040 [DEBUG] [org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter] Finished executing task ':compileJava'
15:30:35.040 [INFO] [org.gradle.execution.taskgraph.AbstractTaskPlanExecutor] :compileJava (Thread[main,5,main]) completed. Took 1.276 secs.

Is there any trick to display more information when compiling the Java classes ? The log doesn’t show what happens at build time.

Providing a test project is quite tricky because the dependencies I use are not accessible in public Maven repos


(Francois Ritaly) #2

This seems to relate to a jar with an invalid signature. The compiler stops abruptly without any error message.

This is the jar causing the issue: org.eclipse.birt.runtime_4.6.0-20160607.jar.

See https://bugs.eclipse.org/bugs/show_bug.cgi?id=497356