Gradle moving from JRE1.8 to JRE11

(kumar) #1

task copyJre(type: Copy) {
// The dependency is an openjdk tarball. copy and extract it.
configurations.copyJre.files.each { file ->
from tarTree(file)
}

getting this error … not sure why looking for jdk1.8 … where i am migrating from jre8 to jre11
and i see we have searching location JDK1.8

A problem occurred evaluating project ‘:licensegenerator’.

Could not resolve all files for configuration ‘:licensegenerator:copyJre’.
Could not find openjdk:openjdk-windows-x86_64:1.8.
Searched in the following locations:
- http://maven-internal.engineering.ark.archivas.com/rest/openjdk/openjdk-windows-x86_64/1.8/openjdk-windows-x86_64-1.8.pom
- http://maven-internal.engineering.ark.archivas.com/rest/openjdk/openjdk-windows-x86_64/1.8/openjdk-windows-x86_64-1.8.tgz
- http://maven-external.engineering.ark.archivas.com/rest/openjdk/openjdk-windows-x86_64/1.8/openjdk-windows-x86_64-1.8.pom
- http://maven-external.engineering.ark.archivas.com/rest/openjdk/openjdk-windows-x86_64/1.8/openjdk-windows-x86_64-1.8.tgz
- file:/home/dkumar/git/anywhere-ivy/openjdk/openjdk-windows-x86_64/1.8/ivy-1.8.xml
- file:/home/dkumar/git/anywhere-ivy/openjdk/openjdk-windows-x86_64/1.8/openjdk-windows-x86_64-1.8.tgz
Required by:

     project :licensegenerator