Gradle Import (importing to Eclipse) wizard doesn't take the gradle location


(lttle Lingzi) #1

Hi, I am using buildships 2.0 and Eclipse Mar 1. I have an existing Gradle projects in Java. My team member can import the project successfully to the Eclipse but when I import, I first get the wizard asking for the Gradle installation folder and I typed in the folder correctly.

When I click on next button and start the import, I encounter an error complaining about the nexus downloading and give me an 503 error. I spent a lot of time without any success. Then, in Eclipse, I open windows --> preference --> gradle --> I manually typed in the gradle location ( same as before), and the import became successful.

My question: why Eclipse didn’t take my typed in location for gradle in the import wizard, instead, it takes a setting from windows --> preference --> gradle --> Gradle User Home.

Thanks.


(Stefan Oehme) #2

Those are two different things. One is your user home, the other is the Gradle installation. I guess your user home contains some authentication properties?


(lttle Lingzi) #3

I agree with you they may be different things, but I have typed in values in both cases the gradle installation location:

C:\gradle\gradle-2.14.1, I have to use Eclipse windows --> preference --> gradle --> Gradle User Home -->C:\gradle\gradle-2.14.1 to make the import work. But others don’t use this, but they just type in C:\gradle\gradle-2.14.1 in the gradle import wizard and they could import that projects OK. So my key question is why I couldn’t import my project by the gradle wizard with the cradle installation folder??


(Stefan Oehme) #4

I can’t tell you based on the provided information, can you please provide a reproducible example?

Setting the Gradle user home to point to a Gradle installation makes no sense. I suspect that your default Gradle user home contains some init script or property that made the import fail. Changing it to anywhere else made it succeed. So without a reproducible example I can just propose you check the contents of your Gradle user home.