Gradle IDEA transitive dependencies

Continuing the discussion from Gradle tooling api ignores configuration transitivity settings:

So after reading through this still not clear for me where is the issue?