Gradle does not use UTF-8 when using ./gradlew run from terminal

Hi there!
I’m struggling with that problem:
I’m implementing a card board game command line version in java for an exam project.
The point is i want to use some UTF-8 character in order to draw some boxes… and after some configuration it works nicely when i run the application from the gradle toolbox inside intelliJ.
Things break when i try to run my project inside a terminal window, by running the command “./gradlew run”, since the characters i’m using to draw boxes are printed as question marks (?).

I’ve already tried things such as

org.gradle.jvmargs=-Dfile.encoding=UTF-8  // inside
compileJava.options.encoding = 'UTF-8'                      //In build.gradle
compileTestJava.options.encoding = "UTF-8"

PS: tha crazy part is that if i try to compile and run a simple class that prints one of such characters it works correctly inside a terminal! So the problem must resides in Gradle!

I’m on Windows 11, using intelliJ, Java 17 and Gradle 7.5
Thank you for you time!