Gradle does http head on the jar even though the maven artifact is of type pom


(Gururaj R) #1

FAILURE: Build failed with an exception.

  • What went wrong: Could not resolve all dependencies for configuration ‘:compile’. > Could not resolve net.jradius:jradius-client:1.1.4.

Required by:

:osu:unspecified

Could not parse POM http://coova-dev.s3.amazonaws.com/mvn/net/jradius/jradius-client/1.1.4/jradius-client-1.1.4.pom

Could not resolve net.jradius:jradius:1.1.4.

Could not parse POM http://coova-dev.s3.amazonaws.com/mvn/net/jradius/jradius/1.1.4/jradius-1.1.4.pom

Could not HEAD ‘http://coova-dev.s3.amazonaws.com/mvn/net/jradius/jradius/1.1.4/jradius-1.1.4.jar’. Received status code 403 from server: Forbidden

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

build.gradle as below:

repositories {

mavenCentral()

maven {

url “http://coova-dev.s3.amazonaws.com/mvn

} }

dependencies { compile ‘net.jradius:jradius-client:1.1.4’ }

The same dependency with maven works fine.


(Peter Niederwieser) #2

Have you tried with the latest Gradle version? As far as I know, Gradle doesn’t support Maven modules of type ‘pom’. You may have to include the transitive dependencies directly.


(Gururaj R) #3

First I had tried with gradle version 1.8 and then used version 1.10 has the same issue. I tried including the transitive dependencies and also exlcuding (exclude group: ‘net.jradius’, module:‘jradius’), but nothing worked. Gradle always does a HEAD on the jar that doesn’t exist.


(Peter Niederwieser) #4

In that case, the known limitation still applies, and you’ll have to add the transitive dependencies directly, rather than adding ‘jradius-client’.