Gradle cant find dependency

Hi, I am new to Gradle and would greatly appreciate some help with figuring out why gradle does not download a dependency from a local repository.

(I apologize in advance for the possibly long and erratic message.)

The only error message I get is:

  • What went wrong:
    Execution failed for task ‘:service:compileJava’.

Could not resolve all files for configuration ‘:service:compileClasspath’.
Could not find
Required by:
project :service

I have set up build.gradle with :

repositories {

maven {
url “http://localhost:8090/releases
allowInsecureProtocol = true


and the artifact is specified as:

I am using reposilite as the local repository, so I am trying to figure out if gradle have tried contacting the repository and in that case what it has asked for, specifically.

I might have misconfigured reposilite, uploaded the artifact wrongly or misconfigured build.gradle, so I just have to start at the most logical place, what is gradle asking for and which server is it talking with.

I have tried --info and --debug, but I cant find any mention of it trying to download the artifact, even though other artifacts are downloaded from public replositories.

I have deleted .ivy2 .m2 and .gradle/caches, to force it to download from the local repo, but to no avail.

Currently I am thinking there is something wrong with the build.gradle definition, but I am using the config snippet provided by reposilite for my repo, so it should be correct, I think.

Again, any help would be greatly appreciated.


Remove the leading colon from the dependency. The format is <group>:<name>:<version>.

Thank you, that was a silly mistake by me. The declaration used to be for loading from a local directory, so I must have forgotten to remove it.

That being said, i think the error message should be a bit more verbose, so it could guide the user to figuring out by himself. The problem was actually on both side, but different problems.

I wasnt sure if it was a definition problem in the file, if it was a network problem (did it actually contact a server at all? or mavenCentral, company repo, or my local repo?), or was it looking in the right place on the server.

I tried using --info and --debug, but that gave me no more useful information

Also, I just realised that if I specify a wrong url or part of it, like a wrong port number, it doesnt say anything about not being able to connect with the server. Shouldnt it at least give a warning, with --info, that the defined server does not exists / is unreachable?
It just says: “Searched the following locations URL(s)” When it in fact did not reach one of the locations, so no search was actually done at that server.

Do you think this is worth a change request/bug report, or can this be solved another way?