Gradle BootRun fails after generateQueryDSL task finishes executing

gradle-3127

(Tony Williams) #1

HI I am using Gradle 3.1 with Spring-Boot 1.2.4. After performing a git pull in the root directory I then run the command gradle BootRun as usual with success. However, now when I run this command, it seems that the build fails after generateQueryDSL task has finished. I’m not sure that anything has changed. Here is a snippet of the code segment:

13:30:56.988 [DEBUG] [org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter] Finished executing task ':generateQueryDSL
13:30:56.988 [INFO] [org.gradle.execution.taskgraph.AbstractTaskPlanExecutor] :generateQueryDSL (Thread[Daemon worker Thread 3,5,main]) completed.
13:30:56.988 [DEBUG] [org.gradle.internal.operations.DefaultBuildOperationWorkerRegistry] Worker root.1 completed (0 in use)
13:30:56.988 [DEBUG] [org.gradle.execution.taskgraph.AbstractTaskPlanExecutor] Task worker [Thread[Daemon worker Thread 3,5,main]] finished, busy:
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter]
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] FAILURE: Build failed with an exception.
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter]
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] * What went wrong:
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] java.lang.UnsupportedOperationException (no error message)
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter]
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] * Try:
13:30:56.989 [ERROR] [org.gradle.internal.buildevents.BuildExceptionReporter] Run with --stacktrace option to get the stack trace.
13:30:56.989 [LIFECYCLE] [org.gradle.internal.buildevents.BuildResultLogger]
13:30:56.989 [LIFECYCLE] [org.gradle.internal.buildevents.BuildResultLogger] BUILD FAILED
13:30:56.989 [LIFECYCLE] [org.gradle.internal.buildevents.BuildResultLogger]
13:30:56.989 [LIFECYCLE] [org.gradle.internal.buildevents.BuildResultLogger] Total time: 1.247 secs


(Tony Williams) #2

If you need more info please let me know. Thanks.


(Tony Williams) #3

OK I believe I fixed it. After some investigation: What happened was that the gradle version I was running was (3.1) was giving me problems. So after looking at the build.gradle (Ruby?) script, I switched to gradle version 2.6. I visited the gradle support community and it was stated - at least back in mid-June - that there were updates made which caused a dependency management spring boot lib file to fail for version 3.1. So that seemed to solve most of the problem however once I got to 83% booted it still failed with Tomcat access error.

It turns out that I had an XAMPP Control monitor running Tomcat (used for PHP I think) so Tomcat was now being used by that app instead of gradle bootRun. When I removed the Tomcat job from that XAMPP application it freed up Tomcat and gave gradle access to it so that I could boot all the dependencies for Awana Club.