Gradle 4.8: Compiler error output details [suddenly] invisible on Travis CI


(Misagh Moayyed) #1

Setup

Description

I can’t seem to find the source or the root cause of the error. All I see in the output is:

> Task :support:cas-server-support-oauth:compileJava
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error
> Task :support:cas-server-support-oauth:compileJava FAILED
> Task :support:cas-server-support-openid-webflow:compileJava
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':support:cas-server-support-oauth:compileJava'.
> Compilation failed; see the compiler error output for details.

This does look like something is crashing, but I don’t know how I might be able to determine that. I have tried using -S or --debug and none seem to fully explain the root cause of the error.

I have tried switching to Gradle 4.9 to see if I can spot a difference; unfortunately, lombok and/or the gradle-lombok plugin and/or incremental compilation simply do not work well together though those are issues for another day :slight_smile:

Questions

  • Are there options I can turn on or tweak to see the “compiler error output”?
  • Could this be something peculiar with Travis CI? (Doubtful, as the build has been running fine on master using the same setup for a while)
  • Suggestions or thoughts on how I might be able to better troubleshoot this?