Gradle 4.6 init plugin


(Raymond Augé) #1

In the 4.6 Gradle documentation there’s a new section for the updated init plugin https://docs.gradle.org/current/userguide/build_init_plugin.html

However, I’ve not gotten any results out of this.

I do have gradle 4.6 installed:

]$ gradle -v

------------------------------------------------------------
Gradle 4.6
------------------------------------------------------------

Build time:   2018-02-28 13:36:36 UTC
Revision:     8fa6ce7945b640e6168488e4417f9bb96e4ab46c

Groovy:       2.4.12
Ant:          Apache Ant(TM) version 1.9.9 compiled on February 2 2017
JVM:          1.8.0_151 (Oracle Corporation 25.151-b12)
OS:           Linux 4.13.0-38-generic amd64

While I realize this is still incubating, is this supposed to work at all in 4.6 as indicated by the manual and also the getting started tutorial https://guides.gradle.org/creating-new-gradle-builds/?_ga=2.228918426.700729751.1522275805-1815854869.1452856834?


(James Justinic) #2

What specifically are you trying that hasn’t gotten any results? I use this quite frequently as a starting point for any incomplete excerpt posted here in the forums, and haven’t observed any unexpected behavior with 4.6.


(Raymond Augé) #3

Thanks for responding James.

Today I tried again, and it just worked :frowning: sigh… I tried yesterday many times after installing but maybe my environment was broken somehow.

What I was trying was simply the most basic process:

  • create a directory
  • init the project using gradle init

from this I was getting an error “the init plugin is not applied” but as above gradle version showed 4.6 so I was confused, but also I may have had a gradle daemon running (though that is also confusing because I typically disable that globally).

Sorry for the noise.

  • Ray